Home Wiki > SDB:Repository di KDE
Sign up | Login

SDB:Repository di KDE

tagline: Da openSUSE.

Questa pagina elenca e descrive i repository di KDE disponibili e fornisce i relativi collegamenti. Non sono supportati ufficialmente.
Attenzione! Evita di mischiare repository appartenenti a diverse versioni di KDE (Stable/Factory/Unstable/...).
Attenzione! I repository KDE:Unstable:SC sono stati cancellati per via della modalità di manutenzione di KDE 4.

Introduzione

L'organizzazione dei repository è basata sulla distinzione tra due gruppi di pacchetti:

  • pacchetti basati sulla KDE SC. Questo gruppo contiene l'ambiente di lavoro Plasma, le librerie principali di KDE, ma anche applicazioni come KMail, Konqueror, ...;
  • pacchetti per le applicazioni basate su KDE/Qt. Questo gruppo contiene le applicazioni basate sulle librerie KDE o Qt come Amarok, Konversation, Quassel, ecc.

Aggiornamenti di manutenzione

A partire da openSUSE 12.3 il gruppo di lavoro della comunità KDE di openSUSE fornisce le nuove versioni minori della KDE Software Compilation distribuita con la versione stabile più recente della distribuzione tramite gli aggiornamenti di manutenzione. Questo significa che i rilasci minori del software KDE vengono forniti senza la necessità di aggiungere repository. Questo si riflette nella modalità con cui sono stati organizzati i repository di KDE.

Al momento sono attive le seguenti tracce di manutenzione:

openSUSE 12.3: includeva KDE SC 4.10 e sono stati forniti gli aggiornamenti di manutenzione fino a KDE SC 4.10.5.

openSUSE 13.1: include KDE SC 4.11.2 e sono stati forniti gli aggiornamenti di manutenzione fino a KDE SC 4.11.5.

openSUSE 13.2: include KDE SC 4.14.2 e gli aggiornamenti di manutenzione verranno forniti tramite il normale canale di aggiornamento.

Sono disponibili...

Sulla base di quanto indicato qui sopra vengono resi disponibili i seguenti repository per gli utenti openSUSE.

Per gli utenti

  • Rilasci aggiornati di KDE Software Compilation
    Sono le versioni più aggiornate di KDE SC così come rilasciate dalla comunità KDE, con l'aggiunta delle patch di openSUSE (rilasciate e non). Disponibili anche per le versioni meno recenti di openSUSE.
  • KDE Extra
    Le versioni più aggiornate delle singole applicazioni di KDE da openSUSE Factory. I pacchetti sono stati creati per le versioni rilasciate della distribuzione. Non è necessario aggiornare anche KDE, ma puoi farlo dato che KDE è compatibile con le versioni successive.

Per i contributori

  • KDE Unstable Extra
    Snapshot alpha, beta e SCM delle applicazioni KDE in corso di sviluppo. Viene compilato solo per i rilasci più recenti di openSUSE a causa delle possibili dipendenze sui pacchetti più nuovi.

Voglio...


Solo applicazioni aggiornate

Se stai utilizzando i pacchetti di KDE ufficiali, supportati e controllati forniti con la distribuzione, questi sono i repository aggiuntivi a tua disposizione.

Una nota speciale per il repository Unstable:Extra. Dato che sempre più programmi KDE vengono aggiornati per utilizzare KDE Frameworks 5, il repository unstable diventerà lentamente obsoleto per gli utenti KDE 4. In un prossimo futuro l'intenzione è quella di eliminare il repository Unstable:SC e di utilizzare Unstable:Extra per le istantanee delle applicazioni in corso di aggiornamento a KDE Frameworks.


Attuale rilascio di KDE SC

L'attuale rilascio di KDE SC. Utilizza questo repository se vuoi avere la versione attuale (e più recente) del software di KDE. Nota che Plasma Desktop non è più parte dei rilasci di KDE poichè, a partire dalla versione 4.11, l'ambiente desktop è in "Long Term Support" (supporto a lungo termine). L'attuale rilascio di KDE SC perciò contiene solamente le applicazioni aggiornate (le librerie di KDE sono state bloccate a partire dalla versione 4.9 e sono incluse solo con un numero di versione incrementato per facilitare il processo di creazione dei pacchetti).

Dato che KDE 4.14 è l'ultimo rilascio maggiore di KDE 4, forniamo solo gli aggiornamenti di manutenzione per openSUSE 13.2. Non avrebbe senso compilare KDE:Current per openSUSE 13.2 dato che forniamo gli stessi pacchetti tramite gli aggiornamenti.

Attenzione! Rimuovi tutti i repository della sezione Solo applicazioni aggiornate se stai per utilizzare KDE:Current.
Versione: 13.2
  • Non ancora disponibili


Factory o KDF (l'ultimo rilascio di KDE SC (comprese le beta e le RC))

Questi repository contengono i pacchetti di KDE in sviluppo per il prossimo rilascio di openSUSE. I repositoy vengono creati solo per openSUSE:Factory.

Come indicato i repository sottostanti saranno disponibili solo quando un nuovo rilascio KDE SC Beta è in corso di definizione.


KDE Frameworks 5 & Plasma 5

Non utilizzare GDM.

I rilasci di KDE Frameworks 5 e Plasma 5. A partire da openSUSE 13.2 le librerie KF5 e i componenti di Plasma5 sono parte dei repository standard della distribuzione. Se vuoi provare e/o utilizzare l'ultimo rilascio puoi utilizzare questo repository. Gli utenti di Factory/Tumbleweed non hanno bisogno di utilizzarlo (ma possono se vogliono), dato che i nuovi rilascio vengono inviati in Factory il prima possibile e sono di solito disponibili nei repository standard in pochi giorni.

I pacchetti di KF5 possono essere installati insieme a KDE SC 4 e Qt 4, mentre quelli di Plasma 5 non lo sono in larga parte. Questo repository viene utilizzato come progetto di sviluppo per openSUSE:Factory. Per aggiungere la sessione tra le opzioni disponibili nel gestore degli accessi, installa il pacchetto plasma5-session. Prima di provare Plasma 5, leggi i problemi noti: https://community.kde.org/Plasma/5.0_Errata


KF5, Plasma 5 e applicazioni instabili basate su KF5

Pacchetti creati giornalmente di KDE Frameworks 5, Plasma 5 e applicazioni basate su KF5 da trunk. Questo repository viene utilizzato come progetto di sviluppo preliminare per il progetto KDE:Framework5 e openSUSE:Factory. A partire dal 12 giugno 2014 i pacchetti di Plasma 5 non sono più installabili insieme a kde-workspace da 4.x.

Prima di provare Plasma 5, leggi i problemi noti: https://community.kde.org/Plasma/5.0_Errata


KDE 3.5.10

Questo è l'ultimo rilascio di KDE 3 in pacchetti per le versioni rilasciate di openSUSE. Vedi questa pagina apposita per i dettagli e i repository.


Qt

Attenzione! Non hai bisogno di aggiungere questi repository se stai utilizzando quelli di KDE sopra elencati. Quei repository includono già i pacchetti appropriati di Qt.

Rilascio di Qt 4

Qt versione 4.x.x attualmente considerato il più stabile e ragionevolmente recente. Non necessario se stai utilizzando KDE:Distro:Factory o KDE:Distro:Stable.

Snapshot di sviluppo di Qt 4.8

Solo per sviluppatori

Snapshot di sviluppo di Qt 4.7

Solo per sviluppatori

Rilascio di Qt 5

Il rilascio stabile più recente di Qt5 (attualmente 5.3.1).

Rilasci di Qt 5.2.x

Solo per sviluppatori. Il rilascio stabile più recente di Qt 5.2 (attualmente 5.2.1).

Snapshot di sviluppo di Qt 5.3

Solo per sviluppatori. Questi snapshot provengono da Gitorious, ramo stabile.

Snapshot di sviluppo di Qt 5.4

Solo per sviluppatori. Questi snapshot provengono da Gitorious, ramo di sviluppo (non ancora funzionante).


Compilare i tuoi programmi utilizzando Qt o KDE

Per compilare i tuoi pacchetti con KDE 4.x o Qt 4.x, scegli uno dei seguenti repository come base per la compilazione (quando aggiungi un repository fai clic su "Avanzate" in basso e seleziona poi il nome del repository nell'elenco):

  • KDE:Qt se vuoi compilare un'applicazione solo Qt con un rilascio stabile di Qt 4.x. Attualmente questo repository contiene Qt 4.8.x;
  • KDE:Qt48 se vuoi usare Qt 4.8.x;
  • KDE:Release:<rilascio di KDE SC> se vuoi compilare un'applicazione KDE 4.x con KDE 4.8.5. Per qualsiasi delle versioni rilasciate di openSUSE;
  • KDE:Distro:Factory se vuoi compilare un'applicazione KDE 4.x con KDE 4.9.x. Per qualsiasi delle versioni rilasciate di openSUSE.

Vedi anche