The wikis are now using the new authentication system.
If you did not migrate your account yet, visit https://idp-portal-info.suse.com/

Portal:Leap/Topics

Icon-distribution.png

Perché cambiare?

Protegge il futuro di openSUSE fornendo un'opzione più stabile per i nostri utenti. Mantenere una distribuzione richiede molto lavoro, specialmente quando la stabilità è un obiettivo. Basando openSUSE su SLE (SUSE Linux Enterprise), il nucleo di openSUSE Leap sarà mantenuto dagli ingegneri di SUSE. Questo significa che otterrà le correzioni e gli aggiornamenti di sicurezza da SLE.

Il progetto openSUSE può quindi sostituire e aggiungere i bit ed i pezzi di software che i contributori vogliono e che sono disposti a mantenere.

openSUSE Leap completerà anche meglio Tumbleweed. Quando c'era una openSUSE, era diviso tra chi voleva un software più recente e chi voleva un sistema stabile. Tumbleweed si rivolge a coloro che desiderano un software più recente, il ché consente al rilascio regolare di svolgere un lavoro ancora migliore nel fornire un sistema altamente stabile.


Icon-usage.png

Come aggiornare openSUSE Leap?

openSUSE Leap ottiene regolarmente le correzioni di bug e gli aggiornamenti di sicurezza. Per applicare gli aggiornamenti di manutenzione ufficiali esegui come root i comandi seguenti (idealmente all'interno di una schermata o una sessione di tmux):

zypper patch

zypper patch applicherà i pacchetti elencati nel file patchinfo.

A volte i repository di terze parti offrono anche degli aggiornamenti di pacchetti che non sono aggiornamenti di manutenzione. Per installare gli aggiornamenti di pacchetti che non sono aggiornamenti di manutenzione esegui come root i comandi seguenti (idealmente all'interno di una schermata o una sessione di tmux):

zypper update

Sono anche disponibili delle applicazioni grafiche per l'aggiornamento del sistema, vedere ad esempio: Aggiornamenti di sistema.

Non confondere zypper update, che installa solo i pacchetti già installati, con zypper dist-upgrade, che invece installa e rimuove i pacchetti, dato che cerca di eseguire un aggiornamento della distribuzione.

Quando viene rilasciata una nuova versione di openSUSE Leap è necessario un aggiornamento della distribuzione. Vedi: SDB:Aggiornamento del sistema.



Icon-info.png

Scegliere tra openSUSE Tumbleweed e openSUSE Leap

La pagina di Tumbleweed spiega se dovresti scegliere Tumbleweed o l'attuale openSUSE Leap 15.2.