The wikis are now using the new authentication system.
If you did not migrate your account yet, visit https://idp-portal-info.suse.com/

Portal:Tumbleweed/Topics

Icon-info.png

Chi dovrebbe provare Tumbleweed?

Qualsiasi utente openSUSE che voglia avere pacchetti più recenti di quelli disponibili nei repository di openSUSE Leap. Tra questi ci sono, ma non solo, un kernel Linux aggiornato, SAMBA, git, desktop, applicazioni per l'ufficio e molti altri pacchetti.

Inoltre, Tumbleweed dovrebbe attirare maggiormente gli utenti esperti, gli sviluppatori di software (che richiedono gli stack software e gli IDE più recenti) e i contributori di openSUSE (che necessitano di una piattaforma affidabile che sia il più vicino possibile a openSUSE Factory pur rimanendo usabile).

Poiché il kernel Linux viene aggiornato assai di frequente, gli utenti che fanno affidamento su moduli driver del kernel di terze parti, inclusi i driver grafici, non dovrebbero utilizzare la distribuzione Tumbleweed. Questo, a meno che non abbiano familiarità con l'aggiornamento di tali driver da soli, oppure che dispongano di un hardware supportato. Per ulteriori dettagli fai riferimento alla sezione "Driver di terze parti" di seguito.

Nota che i repository aggiuntivi di Packman sono disponibili anche per Tumbleweed!


Icon-info.png

Chi dovrebbe usare openSUSE Leap invece di Tumbleweed?

Sebbene venga fatto ogni sforzo per crearli, a questo punto non vi è alcuna garanzia di avere tutti i moduli aggiuntivi, come ad esempio VMware o VirtualBox, disponibili in openSUSE Tumbleweed. E mentre il repository Packman Tumbleweed Essential si adopera per renderli disponibili, non si può garantire che funzioneranno sempre; ciò a causa di possibili incompatibilità con il Kernel Linux, che si evolve rapidamente. I problemi con i driver grafici proprietari sono simili, per cui non è possibile garantire che saranno funzionanti domani solo perché lo sono oggi. Se non sai come compilarti i moduli aggiuntivi del kernel, e non sei interessato ad imparare o a seguire da vicino i vari aggiornamenti, per favore, non usare Tumbleweed.


Icon-usage.png

Come provare Tumbleweed?

Per iniziare con Tumbleweed segui le istruzioni per installare Tumbleweed

Segui la lista di distribuzione di opensuse-factory per ricevere le notifiche sugli aggiornamenti. Nuove istantanee vengono rilasciate non appena sono pronte e hanno superato il QA automatico. Questo può avvenire ogni giorno, ma a volte, quando vengono integrati cambiamenti più grandi, possono volerci anche alcune settimane.


Icon-warning.png

Rolling release non vuol aggiornamenti, ma solo patch e aggiornamenti urgenti

Quando aggiorni Tumbleweed, utilizza sempre il metodo dist-upgrade (come mostrato di seguito). Utilizzando il normale metodo di aggiornamento (che include l'utilizzo di YaST e PackageKit) anziché il metodo dist-upgrade non porterà il sistema all'ultima istantanea, e potrebbe causare dei problemi.

Per mantenere Tumbleweed aggiornato all'ultima istantanea, esegui il seguente comando come root (idealmente all'interno di una schermata o di una sessione tmux):

zypper dup

Tieni presente che potrebbero esserci alcune sottigliezze con gli aggiornamenti, specialmente con più repository. Vedi ad esempio questa recente discussione sull'uso di zypper dup o di zypper up e le proprietà di zypper dup .


Icon-info.png

Codec multimediali

A causa di problemi di licenza, openSUSE non può includere alcuni codec multimediali, ad esempio H.264. Senza questi codec, i video da alcuni siti web, i file musicali, i suoni ecc potrebbero non essere riprodotti. Per fortuna il repository Packman fornisce questi codec (insieme a molte altre cose) per openSUSE. Maggiori dettagli su Packman possono essere trovati nei repository aggiuntivi di pacchetti.

Per aggiungere interamente il repository Packman ed installare i codec mancanti, esegui come root i seguenti comandi:

zypper ar -cfp 90 http://ftp.gwdg.de/pub/linux/misc/packman/suse/\
openSUSE_Tumbleweed/ packman
zypper dup --from packman --allow-vendor-change

Per aggiungere solamente il repository Packman Essentials (che fornisce i codec e lettori audio/video) ed installare i codec mancanti, esegui come root i seguenti comandi:

zypper ar -cfp 90 http://ftp.gwdg.de/pub/linux/misc/packman/suse/\
openSUSE_Tumbleweed/Essentials packman-essentials
zypper dup --from packman-essentials --allow-vendor-change

Dopo aver installato i codec da Packman puoi eseguire il test del lettore video HTML5 di YouTube per vedere se H.264 funziona correttamente in un browser.


Icon-warning.png

Driver di terze parti

A causa del veloce ritmo degli aggiornamenti del kernel su Tumbleweed, i moduli del driver del kernel di terze parti potrebbero non essere così veloci da raggiungere l'ultima versione del kernel. Nel caso improbabile che il tuo modulo driver del kernel non funzioni su Tumbleweed, considera invece di usare openSUSE Leap.

Il driver proprietario di NVidia funziona generalmente molto bene con Tumbleweed.

Il driver proprietario di NVidia per la serie GeForce 400 e per le GPU più recenti può essere installato semplicemente usando, come root, i seguenti comandi:

zypper ar -f https://download.nvidia.com/opensuse/tumbleweed nvidia
zypper inr

In casi molto rari, per esempio se hai bisogno di una versione beta del driver, puoi anche installare manualmente il driver.

Leggi NVidia – la via difficile per i dettagli. Ricordati anche di ricompilare e di reinstallare questi driver di terze parti ad ogni aggiornamento del kernel su Tumbleweed.

In alternativa è possibile utilizzare il repository dkms-nvidia di openSUSE Build Service. Questo repository fornisce i driver NVIDIA che funzionano con dkms (i moduli NVIDIA saranno ricompilati automaticamente per ciascun nuovo aggiornamento del kernel). Contiene anche una varietà di versioni dei driver NVIDIA da usare con schede che non sono supportate o che non si comportano bene con i driver più recenti. Per usare questo repository fai semplicemente clic sul collegamento "Installazione 1-Clic" della versione del driver che vorresti installare qui, oppure esegui come root i seguenti comandi per i driver più recenti da dkms-nvidia:

zypper ar -f https://download.opensuse.org/\
repositories/home:/Bumblebee-Project:/nVidia:/latest/\
openSUSE_Tumbleweed/home:Bumblebee-Project:nVidia:latest.repo
zypper in dkms-nvidia

Nota però che il repository dkms-nvidia non è supportato ufficialmente, ed ognuno che voglia utilizzarlo dovrà probabilmente cavarsela da solo con la risoluzione dei problemi.

Quanto a AMD, AMDGPU-PRO non è supportato in Tumbleweed. Tumbleweed arriva già con un driver Radeon installato, che di solito è comunque la scelta migliore.


Icon-user.png

Come posso contribuire?

  • Puoi provare la distribuzione Tumbleweed e fornire un feedback, condividere le esperienze e partecipare alle discussioni sullo sviluppo. Per fare questo, invia la tua mail all'indirizzo della lista, opensuse-factory@opensuse.org.
    Puoi anche scegliere di ricevere messaggi dalla lista iscrivendoti esplicitamente ad essa. Per fare questo, invia una mail vuota a opensuse-factory+subscribe@opensuse.org. Assicurati di rispondere alla conferma della sottoscrizione che riceverai poco dopo — questo è un meccanismo per evitare che altre persone ti iscrivano involontariamente.
  • Se incontri dei problemi con la tu istanza di Tumbleweed puoi segnalarli con openSUSE bugzilla.
  • Se sei un pacchettizzatore puoi, you can sottoporre nuovi pacchetti al progetto openSUSE:Factory.